Can't add old Tag unless Tag still in use elsewhere?

tags

#1

Hi all

Not sure if I found a bug. Can anyone reproduce or explain what is happening here:

I am setting up a Tag call “In Progress” so members can all see what tasks are actively being worked on.

I have Favorited this Tag for myself so I can quickly view all open tasks with this Tag whenever I feel like.

Everything was going fine in my testing, I could modify tasks, begin typing and the Tag would show in the list for me to select and add to the task. As a task was completed, the Tag would be manually removed before ticking as complete.

But sometime later when I had no tasks in progress, I could not begin typing this tag in a task I was editing. It wanted to make a new Tag, even though I could still see the Tag in my favorites and was still able to use in an advanced search. Adding it as new would make it a duplicate name and not the same Tag as before.

I dragged a task back into my Favorited to give a task the original Tag and then add it back to my original Project. Now I was able to edit other tasks and begin to type “In Progress” to show it as a selectable tag again.

The only workaround I know is to leave a completed task with that Tag applied to it. It works, but perhaps since I never explicitly deleted the tag and advanced search still knows about it, editing a task should still be able to show the old tag too.

Anyway I hope I explained myself. As I say I have a workaround so hopefully just bug reporting :slight_smile:

Marty


BUG: impossible to add an existing tag if it is not used elsewhere
#2

I have the same problem as Mart. I cannot add existing tags if these tags are not connected to any tasks.

Is it a bug?

@Marty_Potter do you find some solution?


#3

Hi @michal.mrozek

No i didn’t revisit this at all. For my needs, leaving a completed task with the tag attached was enough to work around the problem. Normally a completed task does not show. And if you do change the filters to show completed, then logically a completed task means it is no longer “in progress” despite the tag I attached.

For other purposes this might not be appropriate. I suppose by definition though, a tag is meant to be a constant, and perhaps you should think about whether you should be removing tags so frequently. Maybe the project should be a Board instead of a List, but that didn’t suit my needs.

Personally I’d like to see the Task status to have a 3-state toggle: Incomplete, In-Progress, Complete. Or maybe there is a way of doing this another way in Asana.

I didn’t know how else to report this as a bug other than post to this forum. Its a good community here, I’d suggest describing the workflow problem you have and maybe someone can offer ideas. :slight_smile:


#4

Hi @Marty_Potter,
Thanks for your answer. My needs are different. In my workflow I need some additional steps in some cases and I am adding it as a tags. I am using an integration with slack to list all of them. It is very convenient for me.
I found silly workaround: From the list (empty) of tasks connected to the tag is possible to create task via email. When task is created it is possible to add tag to other tasks. Then you could delete task from the email.

This is bug for sure and it should be fixed.