Is it possible to view all custom fields?



Hi all. I’ve looked in every place I can think of but I can’t find a full list of our team’s custom fields. If I go into the manage custom fields section, I can see the five most recently used fields, but I’d like to see the whole list so that I can weed out any redundant or duplicate ones.

Does anyone know if this is possible?


Get to know the people in our Community. A snapshot of #10K members

Hi @Mark_Hudson,

Can you try using the API?[workspace-id]/custom_fields
Replace [workspace-id] with the actual ID of your workspace



Hi @Allen

Thanks for replying. I have to admit, I didn’t even know what API stood for until I just googled it! Would you be able to explain how I locate my workspace ID please?



@Mark_Hudson I’d be glad to assist you here :slight_smile:

Most of the basic queries can be done via the API Explorer. Just select from the left pane which item your query is about. In your case, workspace.

Below, there’s an option for the endpoint (I think this is what they call it) which further determines what data will be retrieved.

You can play around the available parameters, or just simply submit the request.

Here’s what I get:

The ID corresponding to your workspace is the Workspace ID. :slight_smile:

I hope this helps! :smile:



Thanks again @Allen. That looks so much simpler than I thought it would be. Unfortunately, I’m getting this message:

I’m not sure why that should be the case but it looks like I’ll have to contact Asana directly.

I really appreciate your help in getting this far. I’m starting to think it might be a good idea to learn some basic programming. :slight_smile:



Forgot to mention. You need to authorize the explorer to do the query for you. There should be a prompt somewhere at the top of the page. I don’t have it now since I have already authorized it before.


If it doesn’t work, you can still perform the query yourself.

If you have more than 10 workspaces, just increase the limit or remove it completely.

Happy querying!


Oh, yes, the big orange box at the top of the screen that reads ‘Click here to Authorize’! :smile: I’m very embarrassed not have noticed that.

That’s great. Thanks again, @Allen.

Much appreciated.


You are very much welcome! And I’m glad I was able to assist. :smile:
Let me know if you encounter further issues with the API. I’ll try to answer to the best of my knowledge. Otherwise, we’ll have to seek help directly from @Alexis and the developers.


Sorry, @Allen, just one more thing! I’m still struggling to get to a list of all of the custom fields. I’ve tried clicking on explorer and looking for the custom fields category in the drop-down, but it’s not one of the options:

Beyond that, I’m getting stuck. I went back to the link you originally posted and substituted workspace-id for the actual number, then pasted that into Chrome, but that gave me an error message so I’m sure I haven’t done that correctly either.

I’m really not very good at this, so if you could walk me through it as though teaching a complete beginner, I’d really appreciate it.

Sorry for taking up so much of your time!


Actually, I also got an error saying I am a guest or on a free plan, which I think means that only premium users are able to access the list of custom fields.

I would assume that you are a premium user.
Can you share the error message you get using the following link?[workspace-id]/custom_fields

I’ve never tried this so don’t know what to expect. haha.


Haha, no problem. Yes, I’m a premium user. This is the message:

{“errors”:[{“message”:“workspace: Not a recognized ID: [224621366116924]”,“help”:“For more information on API status codes and how to handle them, read the docs on errors:”}]}

I’ve checked it a couple of times, and that’s definitely the id for my organisation workstream.

Any ideas?


I don’t know what happened here but I tried multiple times with different IDs and it seems to be working. I even asked a friend of mine who is a premium user and got a list of custom fields.

Can you check again the ID used? Or try other workspace IDs. If it still doesn’t work, perhaps this is an issue with the API itself, that it’s unable to process that specific ID. Asana support should be able to assist here. :slight_smile:


Success! I just figured out that I was only deleting ‘workspace-id’, and not the ‘%5B’ and ‘%5D’ before and after. I’m assuming they’re the ‘[’ and ‘]’, but I just thought they were part of the code itself. I told you I wasn’t very good at this! :confounded:

Huge thanks for all your help, @Allen. Have a unicorn, my friend:


If only I can like this multiple times. Thanks for the unicorn!! :smile:


Hi Mark,

I see your case is solved, but another way beside using the Asana API is to use the Bridge24 for Asana add-on. Once you are connected to the app, you open the grid view and select My Assigned Tasks. Then, using the grid header, you select the columns you want to see, and all your custom fields will be there, available to be selected.

Hope it will help you,


Thanks very much, Daniel. I had briefly looked at Bridge24 a while ago for a different purpose, but I hadn’t realised it could do that. I’ll give it a try.

Thanks for the tip.


Is it possible to easily delete a custom field? I’m new to Asana and not a developer and I find the developer very confusing.


Hi Crystal

You can delete custom fields by going into the Manage Custom Fields menu, selecting the little gear icon next to the field and choosing Edit Field. The delete option is at the bottom-left:

If you delete a field, it will then be unavailable to all other projects in your team.


Thank you @Mark_Hudson. I had not realized it would delete them from all projects. Perfect!