Newly created tag doesn't stick around


#1

So, I’m trying to programmatically create tasks and tag them. The tags come from an external resource so I need to create them programmatically as well. When I call the tags.create_in_workspace function, I get a response that looks like it was successful, with an ID and everything. When I try to use that ID to retrieve a tag or to tag a task, things don’t work. The tag doesn’t show up using any of the find operations, doesn’t show up in the UI, and I seem unable to tag a task with it.

pls halp


#2

Hey @Jari, without seeing your code, I’m not sure what would be causing this behavior. One possibility is that there are too many tags in your domain (I don’t recall the exact limit but I believe it’s in the tens of thousands). Are you able to create and use new tags in the Asana web product? If so, then you have not reached the hard limit.


#3

I am able to create new tags in the UI. We recently created with workspace.


#4

In that case, I can’t think of any reason why successfully created tags can’t be accessed. Are you using an Asana client library? If not, perhaps try using one to work with tags.


#5

I’m using the official python library. I can post code when I get off work.


#6

Oh, I don’t have a problem with applying successfully created tags (e.g. tags created with the GUI). I have a problem with creating tags using the API.


#7

@Jari, I spoke with an API eng and figured out what’s going on. We hide empty tags in the API as though they’re trashed. So if you create a new tag on a task, then you remove the tag from that task, it gets lost forever. Sorry for the confusion.