Siri integration


#1

Hi,

https://blog.asana.com/2017/11/new-siri-integration-asana-2/
Is someone able to make it work? Siri does not seem to know Asana. Should it be working in French?

Bastien


#2

I haven’t been able to make this work yet. Has the update not shipped yet @Alexis ?


#3

It is working for me here in Malaysia in English, have not tested the French version, need to refresh my school knowledge first :slight_smile:


#4

@paulminors so weird…


#5

Hey @Bastien_Siebman! Yes, it is definitely available in French (https://blog.asana.com/2017/11/new-siri-integration-asana-2/)! I’m just after testing it and it’s working for me. Are both your phone and Siri set to French? Also, are you running the latest version of the Asana app and iOS 11.0.0 or a higher version?


#6

@Marie how do you pronounce Asana in French? :stuck_out_tongue:


#7

@Bastien_Siebman As if there was two “S” in French :slight_smile: Have you managed to use the Siri integration in the end?


#8

Look. That is crazy no?
iOS 11.1.2 and Asana 6.5.0


#9

Hi @Bastien_Siebman I was testing it for German and ran into the same problem the first couple of times. Per @Marie’s advice I made sure my phone’s language was in German and my Siri’s language was in German. Then I told Siri to create a task in Asana. It asked me to give it a name and then it saved it straight away.


#10

Adding to that, if I tell Siri to remind me every Tuesday at a certain time of [Task Name] it creates a recurring task.


#11

Ah it’s working for me now. Very cool!


#12

@Cosmina_Sipos my phone has French menus and Siri talks to me in French so… When I opened up the Asana app yesterday I had a popup about Siri integration. But still not working…


#13

It might not be s language issue because it creates Reminders for me too when using English.


#14

That is so weird. @Alexis does it sound like a bug we should report?


#15

Hi guys,

It still works perfectly fine for me in all 3 languages

I’ve just tried the steps in English, German and French and completed them without any hiccups.
Here is what I do:

iPhone 8 plus.
Version 11.1.2
Asana 6.5.0 (not on any Beta)

  1. Settings-> General -> Language and Region I choose the language of preference i.e. English
  2. Settings -> Siri & Search - Listen for Hey Siri on
  3. Language in Siri set to language of preference i.e. English
  4. I say Hey Siri
  5. This is the most important step: in English I say: Create a task in Asana. In German I say “Erstelle eine Aufgabe in Asana” and in French I say “Dis Siri Créer une tâche en Asana!”
  6. I wait for Siri to process it and ask me what I want to name my task
  7. I give it a name and possibly a frequency and as soon as Siri completes the text to speech action it saves it and I can access the task directly in Asana.

Let me know once you’ve followed these steps if it still doesn’t work, please try to give me the step by step of how you are doing it and what you are saying to Siri and I will try to replicate on my end.

Regards,
Cosmina


#16

Hey @Bastien_Siebman! That’s very strange… Have you tried to reinstall your app just in case? Does it work in English if you switch your language settings? Just wondering if the issue is language related or if it is not working all together! :slight_smile:


#17

@Bastien_Siebman@Marie and @Cosmina_Sipos work at Asana :smile: They’ll be able to help! Thanks all :heartbeat:


#18

I finally managed to do it. In Settings > Siri > Asana I ckecked “Use with Siri”. And when talking I say “Créer une tâche dans Asana” and then I am able to create a task… Will see if I am able to use it again. Thanks for the help everyone!


#19

Well played @Bastien_Siebman! Thanks for sharing the solution! :slight_smile:


#20

@Bastien_Siebman Argh… The missing piece of the puzzle! Thanks for sharing. I was wrecking my brain trying to figure out what was different between our setups. Happy Siri’ing with Asana and let us know on this thread your experience. I love that I can create recurring tasks. That was the thing I was most excited about sharing.