Unable to attach documents from Google Drive

google-drive
error

#1

Unable to connect to Google to attach documents. It continues to show “Please try again later”. Sometimes I get the prompt to enter my google account credentials and then, after I entered my credentials I get the “Please try again later” . Tested on Chrome and Firefox, and incognito mode, always same action. I have read what was already discuss and it hasn’t worked for me. If someone has resolved this problem and can share the steps used it would be greatly appreciated.


#2

Hi @Njideka

You might be getting the error shown due to your browser currently not allowing 3rd party cookies.

Here’s how to enable them in Google Chrome:

  • At the top right, click the three stacked dots and then Settings.
  • At the bottom, click Show advanced settings.
  • In the “Privacy” section, click Content settings.
  • Use the “Cookies” section to change your settings:
  • To allow first-party and third-party cookies, choose Allow local data to be set.
  • To block all cookies, choose Block sites from setting any data. When you use this setting, most sites that require you to sign in won’t work.
  • To allow only first-party cookies and block all third-party cookies, check the box next to “Block third-party cookies and site data.” This setting means that site data cannot be written and read, even if you’ve added a site to the exceptions list and have chosen to allow its cookies.

This is also covered here: https://support.google.com/chrome/answer/95647?co=GENIE.Platform%3DDesktop&hl=en

Let me know how this works!