Wufoo > Asana Webhook Error

tasks
wufoo

#1

Hi guys,

Hoping you can help, and apologies for my lack of knowledge here, I’ve searched through previous topics and couldn’t find anything relative…

Over the past 48 hours, my Wufoo > Asana integration via webhooks has been displaying errors with every submission. The set up is essentially: Wufoo form submitted > task created in Asana.

It seems that Wufoo is trying several times to push to Asana, failing, and then creating several duplicate versions of the same submission - please see screenshots.

I’ve spoken to Wufoo, who’ve relayed that the integration is built on the Asana side and that I should double-check Webhook URLs, which I’ve done - note that this has never happened before and just started a couple of days ago.

Really hoping you guys can help me out!

Many thanks,

Rupe.


#2

Hi Rupert,

Can you DM me the URL of your Wufoo account + the form? We can check our logs to figure out what’s going on, and reply with tips. Sorry for the trouble!

  • R.J.

#3

Hey R.J,

I’m an Asana community virgin… to direct message I do the @ < your name right?


#4

For others reading this thread, I think you can click my name, then click “Message” (but it looks like you figured it out, since I got a DM from you).


#5

Our Wufoo to Asana form submissions are experiencing the exact same issue. Is there yet any remedy or solution?


#6

I have been experiencing the same problem. Once and if there is a connection between wufoo and Asana, the asana project ends up receiving multiple records of the same information. I have never had an issue like this and we have been using asana and wufoo for at least 2 years now.


#7

I’m not sure if it’s a function of the “temporary limits” for “new users” but there appears no way for me to DM you…


#9

Hi Suzanne / Michael,

The latest I’ve been told, both via the forum and personal emails from Asana, is that they’re aware of the issue and are working on it.

I’ve had to re-integrate every single form I have via forums.asana.plus. It takes a while but it’s the only stable solution at the moment. Actually doing the integration is really simple, it’s just the sheer amount of forms you might need to sort out that takes time.

Also, if you have any CSS in the Wufoo form that dictates the names of the tasks in Asana, it won’t work at the moment. The submissions will just be named as per the selection you make on forums.asana.plus, i.e. you can only use one field for the task name. I’ve raised this issue too and awaiting a response.

Hope that helps.

As soon as I hear more I’ll post here for you too.

Rupe.


#10

Rupert,

Nice! Can you point me toward info for the forums.asana.plus option? I cannot seem to find anything of the like in the documentation.

Cheers,

M


#11

Hi Michael,

Yeah of course, I just followed this that they sent over…



You just need to hook up the ‘Wufoo Forms Connector’ via:

  • My Profile Settings
  • Apps
  • Manage Developer Apps
    • Register New Application < Wufoo in this case

From memory, I think I was directed to this forums.asana.plus place along the way. Then it’s a one-by-one job. Note: Have your Wufoo API key and Wufoo URL to hand on another page, you’re going to need to copy and paste it a few times!


#12

Thanks Rupe. I am trying to connect to forms in Asana but it takes me to a page that tells me to “get started”. I click on “get started” and it tells me to login to Wufoo (which I am). All the fields are greyed out. That is as far as I get. I have authorized Wufoo to connect with Asana. Any suggestions?


#13

Hey Suzanne,

When you click ‘Get Started’, you should see this screen:

wf1

The API key can be found in the ‘More’ > ‘API Information’ menu next to any of your forms (in Wufoo).

After you’ve entered that and your Wufoo URL, click next and the following screen should display you forms at the top in a drop down menu, and your Asana projects in another. Once you’ve chosen each, the screen after is just choosing form title, assignees, followers etc. One thing I’ve noticed is that the assignee and follow might not always show up when you are integrating the forms on this screen, however, they still assign to the correct people as per your instruction on the Wufoo form itself.


#14

Thanks for your help. I wasn’t able to add anything in the fields when I got to that screen. It just kept going in a circle. Told me to log in to Wufoo (which I was) and then I would get a redirect error. However, I cleared all my cookies in google and voila – it worked.

Thank you so much!